38
产品文档
控制台使用
基础类问题
应用类问题
网络类问题
安全类问题
常见问题
Ubuntu19 安装Theano出现No module问题

有时候我们经常会遇到Ubuntu19 安装Theano出现“No module named ‘theano.compat.six’”的问题,下面来说一下解决方法。

直接在下载好pythearn2包的目录下,对setup.py文件进行修改:
将  from theano.compat.six.moves import input 改为  from six.moves import input

然后就可以:


python setup.py build
python setup.py install

ps:Ubuntu环境下安装theano

其实在ubuntu安装theano有几种可选方法,最简单的方法 pip install theano,如果缺少什么包就pip install 安装包即可。如果

安装完之后,跑代码出现如下问题:

ImportError: cannot import name ‘downsample'

使用如下命令即可解决:

pip install theano==0.8.2

这个主要是Theano版本更新带来的错误,通过这个改回较老的版本即可。



这条帮助是否解决了您的问题? 已解决 未解决

提交成功!非常感谢您的反馈,我们会继续努力做到更好! 很抱歉未能解决您的疑问。我们已收到您的反馈意见,同时会及时作出反馈处理!